Meeting agenda items not accessible

Incident Report for Leadr

Resolved

While we are continuing to investigate to ensure issues like this do not occur in the future, this incident has been resolved and access has been restored.
Posted Dec 10, 2025 - 11:45 CST

Monitoring

This issue has been resolved, but we're closely monitoring to prevent further difficulties accessing meeting agendas.
Posted Dec 10, 2025 - 11:40 CST

Investigating

We are currently investigating reports of some users being unable to view agenda topics in meetings they are accessing. Our team is looking into this now and working on a quick resolution.
Posted Dec 10, 2025 - 11:36 CST
This incident affected: Leadr application and Mobile Applications.