Service Disruption

Incident Report for Leadr

Resolved

This incident has been resolved. We will continue to monitor closely, but if you are experiencing further issues, please contact support@leadr.com.
Posted Sep 29, 2025 - 10:48 CDT

Investigating

We are currently investigating an issue which is causing page timeouts and login failures for some users.
Posted Sep 29, 2025 - 10:11 CDT
This incident affected: Leadr application and Mobile Applications.