Degraded performance

Incident Report for Leadr

Resolved

We are continuing to monitor performance, but systems are now returned to normal.
Posted Oct 14, 2025 - 10:32 CDT

Identified

We are currently investigating an issue which is slowing load times for some users when attempting to sign in.
Posted Oct 14, 2025 - 10:15 CDT
This incident affected: Leadr application and Mobile Applications.