Downgraded performance

Incident Report for Leadr

Resolved

We have continued to monitor after making improvements, and all portions of the application have been operating steadily for a comfortable period. We will remain watchful for any further hiccups.
Posted Sep 29, 2025 - 15:25 CDT

Investigating

We are currently investigating reports of slow load times and failures to sign in to Leadr.
Posted Sep 29, 2025 - 13:00 CDT
This incident affected: Leadr application and Mobile Applications.