Database Outage

Incident Report for Leadr

Resolved

The application has returned to normal operation.
Posted Aug 22, 2025 - 20:27 CDT

Monitoring

The database is recovering. We will monitor briefly before resolving.
Posted Aug 22, 2025 - 20:15 CDT

Update

Our database provider is actively investigating the interruption.
Posted Aug 22, 2025 - 20:05 CDT

Investigating

Our database provider is experiencing technical difficulties, which has led to an outage of our application. We are pursuing remedy with their team.
Posted Aug 22, 2025 - 19:54 CDT
This incident affected: Leadr application and Mobile Applications.