Delayed API responses

Incident Report for Leadr

Resolved

API latencies have returned to normal ranges. We will continue to monitor closely.
Posted Dec 09, 2025 - 09:55 CST

Identified

We have identified a delay in API responses and are mitigating the issue.
Posted Dec 09, 2025 - 09:51 CST
This incident affected: Leadr application and Mobile Applications.