Degraded Performance

Incident Report for Leadr

Resolved

Response times have stabilized fully. We are exploring additional proactive measures.
Posted Oct 07, 2025 - 09:37 CDT

Monitoring

Response times are improving. We're continuing to work through root cause analysis to prevent future issues.
Posted Oct 07, 2025 - 09:28 CDT

Investigating

We are currently investigating this issue.
Posted Oct 07, 2025 - 09:09 CDT
This incident affected: Leadr application and Mobile Applications.